Opened 6 years ago

Closed 5 years ago

#12861 closed (duplicate)

Docs lack example of how to include a custom JSONEncoder subclass into serializers.serialize()

Reported by: orokusaki Owned by: nobody
Component: Documentation Version: master
Severity: Keywords: serialize, serializers
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In this section http://docs.djangoproject.com/en/dev/topics/serialization/#id2 it describes an example of where you would need a custom encoder class, but gives no example of how to add your class. My guess was using serialize(obj, cls=MyCustomClass), but this raised a "multiple values of 'cls' keyword argument" error. I ended up not needing a custom class, but it might be helpful for others to see it in use.

Change History (2)

comment:1 Changed 6 years ago by russellm

  • milestone 1.2 deleted
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 5 years ago by timo

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #15091

Note: See TracTickets for help on using tickets.
Back to Top