Opened 5 years ago

Closed 5 years ago

#12852 closed (duplicate)

1406, "Data too long for column 'name'..." on syncdb

Reported by: fvlima Owned by: nobody
Component: contrib.admin Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi!

If the an class in django model have more than 40 characters in his name, where you run the syncdb, the error "Data too long..." will be displayed when run syncdb, becouse the table auth_permission have the "name" column with varchar 50. Then, django try create the permissions "can delete", "can change" added with the name of class.

I updated to the most recent version, and this error continues.

Regards,

Fred

Change History (1)

comment:1 Changed 5 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8162.

Note: See TracTickets for help on using tickets.
Back to Top