Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12821 closed (wontfix)

Application settings

Reported by: sorl Owned by: nobody
Component: Core (Other) Version: 1.1
Severity: Keywords: settings
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Providing application default settings is quite painful but still very common. I propose in similarity how the admin.py files can be located using autodiscover to have a settings file in the application directory which if located, values will be added to the settings object. Here is some code that I am using personally, it tries to import settings.py file in the app dir and there is no way to stop that, which i suggest must be optional, what do you think?

Attachments (1)

__init__.py (2.5 KB) - added by sorl 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by sorl

comment:1 Changed 5 years ago by ashwoods

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I started writing a similar patch tonight before I stumbled across this.
Settings in general needs some work, and you can follow where the discussion is going here: http://groups.google.com/group/django-developers/browse_thread/thread/c89e028a536514d3/7a80b7fada8e2c4b?lnk=gst&q=settings.py#7a80b7fada8e2c4b

comment:2 Changed 5 years ago by russellm

  • Resolution set to wontfix
  • Status changed from new to closed

Duplicate of #6546, #5049 and #1371. When Jacob spoke about "application settings", I don't think this is what he had in mind. He's talking about making a clear separation between "settings that influence application behaviour" and "settings that are operational concerns".

comment:3 Changed 4 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top