Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#12805 closed (duplicate)

Raw method docs are misleading

Reported by: vbabiy Owned by: nobody
Component: Documentation Version: 1.2-beta
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

http://docs.djangoproject.com/en/dev/topics/db/sql/#django.db.models.Manager.raw

The first example show that the result Person.objects.raw('SELECT * from myapp_person') is a list of Person object but really it is a RawQuerySet.

Attachments (1)

doc_patch.diff (461 bytes) - added by vbabiy 5 years ago.
Patch that fixes the docs

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by vbabiy

Patch that fixes the docs

comment:1 Changed 5 years ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #12519

comment:2 Changed 3 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Note: See TracTickets for help on using tickets.
Back to Top