Code

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1265 closed defect (fixed)

ImportError exceptions are missing in process_exception

Reported by: wsobczuk@… Owned by: adrian
Component: Core (Other) Version: master
Severity: major Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When an ImportError is raised (and probably others) the aproppriate middleware doesn't handle it - perhaps it can't. In a production environment it is very important to be able to see the cause of all errors (and not just have users redirected to the 500 view).

So I propose to provide some method of being able to handle *all* exceptions and not just the ones in views.

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

Closing this because I don't understand what the issue is, and whether it's already been fixed.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.