Opened 6 years ago

Closed 6 years ago

#12626 closed (invalid)

Empty forms should be valid

Reported by: iElectric Owned by: nobody
Component: Uncategorized Version: 1.1
Severity: Keywords:
Cc: domen@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


>>> django.forms.Form().is_valid()
>>> django.forms.Form({}).is_valid()

The following usecase makes this a bug and unwanted behaviour:

I use session based form wizard in which user can say he has enough between the forms. Because none of the forms has any required fields, this should be doable. However it is not, as when all forms are validated, the one's that are not yet bound fail validation.

Yes, this can be and will be solved at FormWizard, but why such unexpected behaviour?

Change History (2)

comment:1 Changed 6 years ago by iElectric

  • Cc domen@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 6 years ago by Alex

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
Back to Top