Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#12552 closed (fixed)

Adding a user from admin doesn't save password

Reported by: hvdklauw Owned by: nobody
Component: contrib.auth Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


When going to the admin site and adding a user the password field will contain: "!"
Then going to the change password form will set the password.

Attachments (1)

12552.diff (744 bytes) - added by Honza_Kral 6 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by lukeplant

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

I'm not sure what this ticket is about exactly. The user admin page works as intended - you can set the 'password' field manually if you want, in the form [algo]$[salt]$[hexdigest] as described on that page, but to actually set a password, the 'change password form' is much more useful.

comment:2 Changed 6 years ago by jezdez

Actually this is a valid ticket, Django's admin is broken in current trunk due to bug introduced with model-validation and documented in #12521.

comment:3 Changed 6 years ago by Honza_Kral

  • Has patch set
  • Resolution invalid deleted
  • Status changed from closed to reopened

Yes, this is a valid ticket and although caused by #12521 can be resolved without it.

Changed 6 years ago by Honza_Kral

comment:4 Changed 6 years ago by jkocherhans

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [12206]) Fixed #12512. Changed ModelForm to stop performing model validation on fields that are not part of the form. Thanks, Honza Kral and Ivan Sagalaev.
This reverts some admin and test changes from [12098] and also fixes #12507, #12520, #12552 and #12553.

comment:11 Changed 4 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Note: See TracTickets for help on using tickets.
Back to Top