Opened 6 years ago

Closed 5 years ago

#12484 closed (wontfix)

Document that cmemcache is definetly not thread safe

Reported by: anonymous Owned by: nobody
Component: Documentation Version: 1.1
Severity: Keywords: cmemcache
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Using the cmemcache in threaded environment will eventually lead to cache failure.

[FATAL@1262456081.210803] mcm_get_line():1547: memcache(4) protocol error: no \r before \n
[FATAL@1262456081.282046] mcm_get_line():1547: memcache(4) protocol error: no \r before \n
[FATAL@1262456081.282084] mcm_fetch_cmd():1159: memcache(4) protocol error: protocol, expected a response
[FATAL@1262456081.761118] mcm_get_line():1547: memcache(4) protocol error: no \r before \n

Steps to reproduce:

  1. /usr/sbin/ab -n 100 -c 2 http://example.com/my_cached_page

Maybe the solution is to use threading.local to store cmemcache objects.

Change History (3)

comment:1 Changed 6 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 5 years ago by russellm

  • Component changed from Cache system to Documentation
  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 5 years ago by timo

  • Resolution set to wontfix
  • Status changed from new to closed

Since support for cmemcache was deprecated in 1.2 due to a lack of maintenance on the cmemcache library itself, probably not worth fixing.

Note: See TracTickets for help on using tickets.
Back to Top