Code

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1239 closed defect (duplicate)

Please remove the catch-all try/except in template rendering

Reported by: richard at commonground com au Owned by: adrian
Component: Template system Version: 0.90
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If a call from a template fails, I want to see it!

Currently, if I have {{ some_function_call }} in a template, and the call raises an exception, I won't have any information about why it failed. Nothing in the browser, the page source or the server log.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by hugo

You really should provide more specific samples when you don't see a traceback in your debug output, because I definitely know that the system does show tracebacks when exceptions arise. Those tracebacks sometimes might not be perfect in showing what happens (you may need to disable or enable TEMPLATE_DEBUG, because the template debugging code might mask out other stuff sometimes), but you usually do get a traceback.

So some samples might be in order so we know where there might be a problem. Of course the best thing would be a reduced test case we can add to the unittests :-)

comment:2 Changed 8 years ago by russellm

How is this not a duplicate of #1236 (which you submitted yesterday, and I have asked you about)?

May I suggest a quick read through of How to ask Smart Questions. In order to verify, fix, and prevent a bug we need a repeatable, standalone test case, or at the very least a comprehensive set of step by step instructions of how to reproduce the problem.

comment:3 Changed 8 years ago by jacob

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1236

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.