Code

Opened 5 years ago

Closed 5 years ago

#12376 closed (duplicate)

Nested blocks don't work inside an ifnotequal tag

Reported by: Manuel Strehl <m.strehl@…> Owned by: nobody
Component: Template system Version: 1.1
Severity: Keywords: nested block
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The blocks inside a 'master' block can't be overwritten, if they are inside an {% ifnotequal %} tag (and, I suspect, any other 'if'-like tag, too). Consider this master template for basic pagination:

http://dpaste.com/hold/133172/

If I want to overwrite {% block pagination_start %}, the extending template is ignored alltogether:

http://dpaste.com/hold/133173/

which displays exactly the same as the master template.

Expected Output:

The rendering should be like the master, but the first and the last list item should have vanished.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by emulbreh

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6510.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.