Code

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#12370 closed (fixed)

Test management command accepts a parameter extra_tests, which defaults to []

Reported by: rpbarlow Owned by: kmtracey
Component: Testing framework Version: 1.1
Severity: Keywords: test extra_arguments
Cc: randallpbarlow@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This isn't a problem in practice, because only the Django runtests.py test suite uses it, and it only gets called once, but it is bad Python form and so should be fixed.

Attachments (1)

ticket_12370.patch (754 bytes) - added by rpbarlow 4 years ago.
This patch makes us look undumb.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by rpbarlow

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Status changed from new to assigned

Changed 4 years ago by rpbarlow

This patch makes us look undumb.

comment:2 Changed 4 years ago by rpbarlow

  • Has patch set
  • Owner changed from rpbarlow to kmtracey
  • Status changed from assigned to new

Hey Karen, this one is good to go!

comment:3 Changed 4 years ago by rpbarlow

  • Cc randallpbarlow@… added

comment:4 Changed 4 years ago by ramiro

  • milestone changed from 1.2 to 1.1
  • Version changed from SVN to 1.1

This was fixed in trunk in r12255. Leaving this ticket open so a committer can decide if this is worth fixing in the .1.1.X branch.

comment:5 Changed 4 years ago by kmtracey

  • Resolution set to fixed
  • Status changed from new to closed

It's code cleanup, not a bugfix, so should not go into 1.1.X.

comment:6 Changed 3 years ago by jacob

  • milestone 1.1 deleted

Milestone 1.1 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.