Opened 6 years ago

Closed 6 years ago

#12284 closed (duplicate)

Inclusion tags should handle arguments not present in the context gracefully

Reported by: kuon Owned by: nobody
Component: Template system Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


If we call an inclusion tag like that

{% my_tag object %}

and object is not present in the context, an exception will be raised, thus obliging us to do:

{% if object %}
{% my_tag object %}
{% else %}
{% my_tag %}
{% endif %}

It would be better to have the inclusion tag mechanism to handle keys not present in the context and just default them to None.

Change History (1)

comment:1 Changed 6 years ago by kuon

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12283 , sorry about that.

Note: See TracTickets for help on using tickets.
Back to Top