Code

Opened 4 years ago

Closed 4 years ago

#12225 closed (duplicate)

sql/*.sql files don't work if they contain %

Reported by: monikasulik Owned by: nobody
Component: Database layer (models, ORM) Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm getting a "tuple index out of range" error if I don't escape % characters in my app_name/sql/*.sql files (which, unless I'm mistaken, I shouldn't really have to do). I'm using psycopg2 (if this matters). The example code I'm attaching also causes a second error, which seems to have something to do with whitespace, but I think that one was already reported here.

Attachments (1)

sql_file_bug.tar.gz (484 bytes) - added by monikasulik 4 years ago.
This app will cause the error when syncdb is performed.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by monikasulik

This app will cause the error when syncdb is performed.

comment:1 Changed 4 years ago by anonymous

  • Cc monikasulik@… removed
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 4 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of 3214

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.