Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#12200 closed (duplicate)

Template filter for truncating text (characters)

Reported by: paulschreiber Owned by: nobody
Component: Template system Version: 1.1
Severity: Keywords: text string truncate characters
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


There's a template tag for truncating text based on word count (truncatewords), but not on character count. I wrote truncate() (truncate_head(), truncate_middle(), truncate_tail()) to do this.

Attachments (1) (3.4 KB) - added by paulschreiber 6 years ago.

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by paulschreiber

comment:1 Changed 6 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5025.

comment:2 Changed 4 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Note: See TracTickets for help on using tickets.
Back to Top