Code

Opened 4 years ago

Closed 4 years ago

#12159 closed (worksforme)

Installation procedure does not set correct permissions on template files

Reported by: jribbens Owned by: nobody
Component: Core (Other) Version: 1.1
Severity: Keywords: install TemplateDoesNotExist tutorial
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The standard 'python setup.py install' procedure for django does not set the file permissions correctly on the template files that it installs under the /usr/local/lib/python2.6/site-packages/django directory.

This means that when you try to go through the tutorial, when you try to view the /admin/ page for the first time, you get a TemplateDoesNotExist exception.

I had to do:

chmod -R og+rX /usr/local/lib/python2.6/site-packages/django/

to get my django installation working.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

We have plenty of evidence that the installation procedure works, and I just tested it myself and it worked fine for me.

It's difficult to know what is going on here - you haven't provided any of the details that would help us reproduce your problem, like, for example, operating system, the version you tried to install, and the exact installation procedure you followed.

Closing worksforme. If you care to provide more explicit instructions for reproducing your problem, please reopen.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.