Opened 5 years ago

Closed 5 years ago

#12035 closed (duplicate)

admin docs field dictionary miss GIS type informations

Reported by: elpaso66 Owned by: nobody
Component: GIS Version: 1.1
Severity: Keywords: gis admindocs
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This result in an error while browsing admin docs:

KeyError at /admin/doc/models/risorse.poi/

'PointField'

Request Method: 	GET
Request URL: 	http://127.0.0.1:8000/admin/doc/models/risorse.poi/
Exception Type: 	KeyError
Exception Value: 	

'PointField'

Exception Location: 	/trunk/django/contrib/admindocs/views.py in get_readable_field_data_type, line 369

This can be easily solved adding

Index: views.py
===================================================================
--- views.py    (revisione 11602)
+++ views.py    (copia locale)
@@ -359,6 +359,14 @@
     'URLField'                  : _('URL'),
     'USStateField'              : _('U.S. state (two uppercase letters)'),
     'XMLField'                  : _('XML text'),
+    'PointField'                : _('GIS Point'),
+    'LineStringField'           : _('GIS Line'),
+    'PolygonField'              : _('GIS Polygon'),
+    'MultiLineString'           : _('GIS Multiple Line'),
+    'MultiLinePoint'            : _('GIS Multiple Point'),
+    'MultiLinePolygon'          : _('GIS Multiple Polygon'),
+    'GeometryCollectionField'   : _('GIS Geometry Collection')
+
 }

 def get_readable_field_data_type(field):

Change History (1)

comment:1 Changed 5 years ago by jbronn

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7977.

Note: See TracTickets for help on using tickets.
Back to Top