Opened 7 years ago

Closed 7 years ago

#12025 closed (duplicate)

Show generic relation on deleted objects

Reported by: rui.coelho@… Owned by: nobody
Component: Uncategorized Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: UI/UX:

Description

Generic foreign key relations are deleted but not shown in confirmation page.

Attachments (5)

t12025_r11366.patch (2.0 KB) - added by rui.coelho@… 7 years ago.
t12025_r11366.2.patch (8.9 KB) - added by anonymous 7 years ago.
added callback to edit confirmation message, merged with ticket #6191
t12025_r11366.3.patch (8.9 KB) - added by anonymous 7 years ago.
add related object to callback
t12025_r11366.4.patch (9.7 KB) - added by anonymous 7 years ago.
add delete confirmation for top (deleted) obj
t12025_r11366.5.patch (9.7 KB) - added by anonymous 7 years ago.
syntax error fixed

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by rui.coelho@…

Attachment: t12025_r11366.patch added

Changed 7 years ago by anonymous

Attachment: t12025_r11366.2.patch added

added callback to edit confirmation message, merged with ticket #6191

Changed 7 years ago by anonymous

Attachment: t12025_r11366.3.patch added

add related object to callback

comment:1 Changed 7 years ago by Alex Gaynor

Patch needs improvement: set

This patch uses a mutable default value which is bad practice and will cause it to fail when called more than once.

Changed 7 years ago by anonymous

Attachment: t12025_r11366.4.patch added

add delete confirmation for top (deleted) obj

comment:2 Changed 7 years ago by Alex Gaynor

This patch a) still has the mutable default value, and b) includes django.contrib.contenttypes in the ORM, we want to work to reducing that dependency, not increasing it.

comment:3 in reply to:  2 Changed 7 years ago by anonymous

Replying to Alex:

This patch a) still has the mutable default value, and b) includes django.contrib.contenttypes in the ORM, we want to work to reducing that dependency, not increasing it.

a) Which mutable default value are you talking about, is it "objs_seen", if yes, you suggest to start this value with what and why ??

b) Humm, ok, i will see what i can do to avoid that. If you have a suggestion i would appreciate.

Changed 7 years ago by anonymous

Attachment: t12025_r11366.5.patch added

syntax error fixed

comment:4 in reply to:  2 Changed 7 years ago by Carl Meyer

Replying to Alex:

This patch a) still has the mutable default value, and b) includes django.contrib.contenttypes in the ORM, we want to work to reducing that dependency, not increasing it.

Unfortunately the ORM already depends on contrib.contenttypes in at least one other place: source:/django/trunk/django/db/models/sql/subqueries.py#29 - agree that we should be looking to get rid of that, not add more dependency.

This patch would be eclipsed by the patch on #6191, which replaces the admin's related-objects-finding with delegation to the actual ORM code. I'm looking at what it would take to fix this as part of #6191.

comment:5 Changed 7 years ago by Russell Keith-Magee

Resolution: duplicate
Status: newclosed

Closing as a duplicate of #6191.

Note: See TracTickets for help on using tickets.
Back to Top