Code

Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#11975 closed (fixed)

invalid sql returned from django.db.backends.sqlite3.DatabaseOperations.date_trunc_sql

Reported by: akonsu@… Owned by: fgallina
Component: Database layer (models, ORM) Version: master
Severity: Keywords: sqlite DatabaseOperations pycamp2010 djangosprint famaf
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

this method returns 'django_date_trunc("<precision>", <field>)'. in sqlite3, double quoted strings are identifiers, and string literals are single quoted (see http://www.sqlite.org/lang_keywords.html). so it should return "django_date_trunc('<precision>', <field>)". this breaks code such as the following:

MyModel.objects.extra(select={'year':connection.ops.date_trunc_sql('year', '"mymodel"."date"')}).values('year').order_by().annotate(total=Count('pk')) 

the resulting query:

[{'time': '0.007', 'sql': u'SELECT (django_date_trunc("year", "mymodel"."date")) AS "year", COUNT("mymodel"."id") AS "total" FROM "mymodel" GROUP BY django_date_trunc("year", "mymodel"."date")'}] 

same problem exists with date_extract_sql()

Attachments (1)

bug11975.patch (2.0 KB) - added by fgallina 4 years ago.
Tests for bug #11975

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by russellm

  • milestone set to 1.2
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 4 years ago by fgallina

  • Owner changed from nobody to fgallina

comment:3 Changed 4 years ago by fgallina

  • Resolution set to fixed
  • Status changed from new to closed

I was not able to reproduce this issue. My guess is that it was fixed in this revision[0].

Attached is a patch which adds a test for this bug.

[0] http://code.djangoproject.com/changeset/12573/django/trunk/django/db/backends/sqlite3/base.py

comment:4 Changed 4 years ago by fgallina

  • Has patch set

comment:5 Changed 4 years ago by fgallina

  • Keywords pycamp2010 djangosprint famaf added

Changed 4 years ago by fgallina

Tests for bug #11975

comment:6 Changed 3 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.