Opened 6 years ago

Closed 6 years ago

#11947 closed (duplicate)

The use of '/media/' for static file serving

Reported by: jscausey Owned by: nobody
Component: Documentation Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:



An exceptionally annoying problem that I've solved thrice and forgotten twice :)

When using the static file serving capabilities of the Django dev server (as accessed from, you CANNOT use the directory '/media/' to serve your own media files as this dir is used by the admin. In my never ending search for concise names, I invariably end up trying to use the name '/media/' and ponder over 'file not found' errors for quite a bit. Then comes the permission changing, to no avail. And finally, the realization that I've done this before...

In any event, there's no problem with Django here. I'd just like to see this called out in the static files serving doc ( so I (and others) don't waste time on this again.

Thanks for such an awesome framework!

Change History (2)

comment:1 Changed 6 years ago by jscausey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

BTW, this is called out at the bottom, but as regular text (I didn't notice it until I just reread the page). If possible, could this be called out as a warning (with appropriate color, etc)?

comment:2 Changed 6 years ago by ubernostrum

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of either #10213 or #2891.

Note: See TracTickets for help on using tickets.
Back to Top