Opened 6 years ago

Closed 6 years ago

#11856 closed (duplicate)

HttpRequest.path_info not mentioned in docs

Reported by: schmilblick Owned by: nobody
Component: Documentation Version: 1.0
Severity: Keywords: HttpRequest request path path_info
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I've been looking for a way to use different index (/) views for different subdomains.
So far I had been using a middleware component to pry out the subdomain, and then have a bunch of checks in the default index view.

I wanted to split that up to different views, and someone suggested that i could modify the request path in my middleware so another urlpattern would match thus using another view.

I looked at: http://docs.djangoproject.com/en/dev/ref/request-response/#django.http.HttpRequest
Found HttpRequest.path, changed it, nothing happened.
After some digging i found HttpRequest.path_info, modified it and it worked.

So, why isn't path_info in the docs? Is it being removed? Was it recently added?

Change History (1)

comment:1 Changed 6 years ago by dc

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10328

Note: See TracTickets for help on using tickets.
Back to Top