Opened 6 years ago

Closed 6 years ago

#11823 closed (duplicate)

Flush command should allow to choose send/not send syncdb signal and call/not call loaddata command

Reported by: kapa77 Owned by: nobody
Component: Uncategorized Version: 1.1
Severity: Keywords: flush command
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The flush command is sending syncdb signal at the end of it's run. It can be problematic with contenttype app installed. I have this situation:
I have old version of app with contentype app installed, I wrote new version of part of my project and now i want to dumpdata from old db and loaddata on new db.
There is script that ports data from old to new db. The problem id that i have generic relations and they have relation to content types, and when i run flush content type app is creating conten types in db but in different order than i have in my old db, and with this my generic relation are broken.

Attachments (1)

flush_patch.txt (1.9 KB) - added by kapa77 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by kapa77

comment:1 Changed 6 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

At the core, this is really a duplicate of #7052. Changing the behaviour of flush isn't the solution. We need to fix the real problem - handling serialization and deserialization of data that is created dynamically during synchronization.

Note: See TracTickets for help on using tickets.
Back to Top