Code

Opened 5 years ago

Closed 5 years ago

#11773 closed (duplicate)

Porxy Model registered in Model Admin are only visible to Super User

Reported by: coulix Owned by: nobody
Component: Core (Management commands) Version:
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

  • MyUser model proxy User.
  • Register an admin for MyUser

Only super user can see it, even giving all permissions to an admin does not make him see the interface.
It has to be a superadmin.

Is that wanted ?

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

This is effectively a duplicate of #11154. Your user may have "all" permissions, but Django doesn't explicitly create permissions for Proxy classes. As a result, your non-superuser doesn't have permission to view, change or delete the proxy User.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.