Code

Opened 5 years ago

Closed 4 years ago

#11761 closed (fixed)

DB error on TestCase execution

Reported by: dmishe Owned by: nobody
Component: Uncategorized Version: 1.1
Severity: Keywords:
Cc: dmishe@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

While testing my app, everything was ok, when suddenly postgres
started to throw errors (in log) like this:

INSERT INTO "auth_permission" ("name", "content_type_id", "codename")
VALUES (E'Can add item_
deferred_added_by_id_date_added_date_updated_item_type_prefix_raw_title_search_data_slug_subtitle_title',
17,
E'add_item_deferred_added_by_id_date_added_date_updated_item_type_prefix_raw_title_search_data_slug_subtitle_title')

I don't know why django thinks i have a model with such name. I have
model Item with fields added_by, date_added and so on from that INSERT
line.

I've attached a small but very obscure test suite which fails,
i have no idea why, but removing anything from it will result in test running OK.

Django 1.1, postgres 8.3.7, mysql (tested on myisam and innodb) 5.0.

Attachments (2)

tests.py (509 bytes) - added by dmishe 5 years ago.
testcase
model.py (1.3 KB) - added by dmishe 5 years ago.
model, if that helps?

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by dmishe

testcase

Changed 5 years ago by dmishe

model, if that helps?

comment:1 Changed 5 years ago by dmishe

  • Cc dmishe@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 4 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

I suspect this is a dupe of #11936, which has been fixed in [11938]. Please reopen if the problem still exists for you.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.