Opened 6 years ago

Closed 2 years ago

#11754 closed Bug (wontfix)

mod_fastcgi documentation should specify full path to .fcgi script

Reported by: joeforker Owned by: nobody
Component: Documentation Version: 1.1
Severity: Normal Keywords: deployment
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

http://docs.djangoproject.com/en/dev/howto/deployment/fastcgi/

FastCGIExternalServer /home/user/public_html/mysite.fcgi -host 127.0.0.1:3033

is followed by

RewriteRule ^/(.*)$ /mysite.fcgi/$1 [QSA,L]

which must rewrite to /home/user/public_html/mysite.fcgi, not just /mysite.fcgi/, if the documentation is followed to the letter.

Change History (8)

comment:1 Changed 5 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Marking as a duplicate of #11694, which calls for a general rework of the fastcgi docs.

comment:2 Changed 5 years ago by PaulM

  • Keywords deployment added
  • milestone set to 1.3
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Triage Stage changed from Unreviewed to Accepted

I'm re-opening this as it does document an apache-specific issue with the fastcgi docs. The issue that it is marked as duplicating documents a different lighttpd specific issue.

I'm helping re-work the fastcgi docs and don't want this to get lost in the shuffle.

comment:3 Changed 4 years ago by julien

  • Severity set to Normal
  • Type set to Bug

comment:4 Changed 4 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

comment:11 Changed 3 years ago by aaugustin

  • UI/UX unset

Change UI/UX from NULL to False.

comment:12 Changed 3 years ago by aaugustin

  • Easy pickings unset

Change Easy pickings from NULL to False.

comment:13 Changed 2 years ago by aaugustin

  • Status changed from reopened to new

comment:14 Changed 2 years ago by timo

  • Resolution set to wontfix
  • Status changed from new to closed

FastCGI is being deprecated.

Note: See TracTickets for help on using tickets.
Back to Top