Code

Opened 5 years ago

Closed 5 years ago

#11708 closed (duplicate)

django.contrib.markup: pass docutils Writer as argument to restructuredtext template filter

Reported by: Chris.Wesseling@… Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords: rst markup Writer template filter
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Adds optional passing of a custom writer_name to restructuredtext template filter. Defaults to the standard html4css1 Writer from docutils.writers.

So

{{ value|restructuredtext }}

will give you standard html output and

{{ value|restructuredtext:"custom" }}

will user the Writer class from the custom module.

See the docutils documentation for more info.

Attachments (1)

rst.patch (1.2 KB) - added by Chris.Wesseling@… 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by Chris.Wesseling@…

comment:1 Changed 5 years ago by dc

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #11342

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.