Code

Opened 5 years ago

Closed 5 years ago

#11676 closed (duplicate)

Allow '.' for username

Reported by: fterrier Owned by: nobody
Component: Uncategorized Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: yes
Needs tests: yes Patch needs improvement: yes
Easy pickings: UI/UX:

Description

This patch allows users to use '.' in their usernames.

Attachments (1)

username_regex_patch.diff (1.2 KB) - added by fterrier 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by fterrier

comment:1 Changed 5 years ago by dc

  • Has patch set
  • Needs documentation set
  • Needs tests set
  • Patch needs improvement set
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5786 (and many other tickets).

Your patch is wrong: regex allows use !@#$%^&*()-+{}?'"|\/ and any other non-whitespace character in username.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.