Code

Opened 5 years ago

Closed 5 years ago

#11664 closed (invalid)

Invalid SQL is generated as part of the aggregation unit tests

Reported by: egenix_viktor Owned by: nobody
Component: Database layer (models, ORM) Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The following Django 1.1 unit tests seem to generate invalid SQL: aggregation, aggregation_regress. It happens even if I run then on SQLite.

The generated SQL always contains a strange GROUP BY clause, like this:

GROUP BY aggregation_book, aggregation_book, aggregation_book, aggregation_book, aggregation_book, aggregation_book, aggregation_book, aggregation_book, aggregation_book

The table name varies with the actual unit test. It happens several times.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

We're going to need some more information here, as I am absolutely unable to reproduce.

comment:2 Changed 5 years ago by mtredinnick

  • Resolution set to invalid
  • Status changed from new to closed

I've printed out the SQL from every single call in those functions and this isn't happening. Closing for now. Please reopen if you have a step-by-step set of instructions to reproduce, but the above would imply that aggregation was broken and it wouldn't even execute (the database would complain). That isn't the case, so I think it's a problem on the reporter's side.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.