Opened 7 years ago

Closed 7 years ago

#11650 closed (wontfix)

Add .gitignore for unofficial mirrors.

Reported by: Adam Vandenberg Owned by: nobody
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I mostly expect this to be "won't fixed", but it would be very useful for unofficial git mirrors if Django had at least a basic .gitignore file that excluded .py[c|o] files.

Attachments (1)

gitignore.diff (155 bytes) - added by Adam Vandenberg 7 years ago.
Ignore cached py files and built docs.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Adam Vandenberg

Attachment: gitignore.diff added

Ignore cached py files and built docs.

comment:1 Changed 7 years ago by Alex Gaynor

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Triage Stage: UnreviewedDesign decision needed

comment:2 Changed 7 years ago by Masklinn

If there are ignore files for unofficial mirrors to be provided by Django, it would make sense to provide it for all SCM types that could be used for mirrors. Or at the bare minimum the three "big" ones: Git, Bazaar and Mercurial.

by the way, I just checked and I note that in my local Django copy, the svn ignores are incomplete on the 1.0.X release branch:

$ svn st
?       django/contrib/localflavor/ro/forms.pyc
?       django/contrib/localflavor/ro/__init__.pyc
?       django/contrib/localflavor/at/forms.pyc
?       django/contrib/localflavor/at/at_states.pyc
?       django/contrib/localflavor/at/__init__.pyc
?       tests/regressiontests/model_forms_regress/__init__.pyc
?       tests/regressiontests/model_forms_regress/models.pyc
?       tests/regressiontests/bug8245/admin.pyc
?       tests/regressiontests/bug8245/__init__.pyc
?       tests/regressiontests/bug8245/tests.pyc
?       tests/regressiontests/bug8245/models.pyc
?       docs/_ext/djangodocs.pyc

comment:3 Changed 7 years ago by Jannis Leidel

Being the maintainer of the Git mirror I don't see a need for this change since all DVCS allow global ignore files, e.g. git config --global core.excludesfile ~/.gitignore.

comment:4 Changed 7 years ago by Adam Nelson

I think this would be nice in order to reduce the burden for new developers. Not many people know how to create a system-level .gitignore file. Anyway, with a big project there will be special excludes that are specific to the project. This could also just be done on the other repository and not on the official one.

As for other repos, I don't think there is a Mercurial or Bazaar mirror so those could be safely ignored until a repo exists.

comment:5 Changed 7 years ago by Jannis Leidel

Resolution: wontfix
Status: newclosed

Closing this as wontfix since this isn't a Django issue.

Note: See TracTickets for help on using tickets.
Back to Top