Code

Opened 5 years ago

Closed 8 weeks ago

Last modified 8 weeks ago

#11605 closed Bug (worksforme)

manage.py syncdb breaks for some proxy models

Reported by: jds Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: yes Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

If the proxy model is in an application listed before the parent model's application, the table does not get created.

I have an application, testapp, with this testapp/models.py:

from django.contrib.auth.models import User

class MyUser(User):
    class Meta:
        proxy = True

INSTALLED_APPS has testapp listed before django.contrib.auth. The auth_user table does not get created.

This is related to #11428. The patch shows where the issue is.

If this is intended behavior, a small addition to the Available Settings > INSTALLED_APPS documentation would clear this up.

Attachments (1)

patch.diff (1.2 KB) - added by jds 5 years ago.
agains 11368

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by jds

agains 11368

comment:1 Changed 5 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 5 years ago by pcardune

Just encountered this problem myself.

comment:3 Changed 5 years ago by thejaswi_puthraya

  • Component changed from Uncategorized to Database layer (models, ORM)

comment:4 Changed 3 years ago by julien

  • Severity set to Normal
  • Type set to Bug

comment:5 Changed 3 years ago by julien

  • Needs tests set

comment:6 Changed 2 years ago by aaugustin

  • UI/UX unset

Change UI/UX from NULL to False.

comment:7 Changed 2 years ago by aaugustin

  • Easy pickings unset

Change Easy pickings from NULL to False.

comment:8 Changed 8 weeks ago by nott

  • Resolution set to worksforme
  • Status changed from new to closed

comment:9 Changed 8 weeks ago by nott

Works for me on master.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.