Code

Opened 5 years ago

Closed 3 years ago

#11576 closed (duplicate)

FilterSpec and Null values

Reported by: twiinz@… Owned by: nobody
Component: contrib.admin Version: 1.0
Severity: Keywords: FilterSpec
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

FilterSpec don't do much at the moment concerning fields that accept Null values.

I patched DateFieldFilterSpec to fix this issue.

I believe the same can be done for the rest of the FilterSpec.

For the BooleanFieldFilterSpec, I wonder why not checking self.field.null instead of requiring the developers to define a NullBooleanField in their model.

Attachments (2)

filterspecs.py.patch (127 bytes) - added by twiinz@… 5 years ago.
filterspecs.py.2.patch (582 bytes) - added by twiinz@… 5 years ago.
Proper SVN patch

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by twiinz@…

Changed 5 years ago by twiinz@…

Proper SVN patch

comment:1 Changed 5 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 3 years ago by julien

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #8528.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.