Code

Opened 5 years ago

Closed 5 years ago

#11494 closed (duplicate)

syncdb fails silently to create tables for an app where the app has an import error

Reported by: lawgon <lawgon@…> Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords: syncdb
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I am using latest trunk. This is the same behaviour as reported in #10706. To replicate create an app, this app should import something that is not available, but should not have any syntax error. That is, from the shell 'import app' should work and 'from app import *' should raise an exception. In these circumstances syncdb will fail silently to create any tables for the app.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by gav

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

As you said in your ticket, duplicate of #10706. Closing in favor of that ticket.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.