Rename misleadingly named sql_create_table_suffix function
|Reported by:||seveas||Owned by:||nobody|
|Component:||Database layer (models, ORM)||Version:||master|
|Has patch:||yes||Needs documentation:||no|
|Needs tests:||no||Patch needs improvement:||no|
While investigating a way to implement a new feature I wanted, I came across the sql_create_table_suffix function in django.db.backends.creation and subclasses. This function has a misleading name as it is only used when creating the test database. Attached patch renames the function to say what it does.