Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11401 closed (fixed)

OSM Admin broken after OpenLayers updated to version 2.8

Reported by: yourcelf Owned by: nobody
Component: GIS Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

OpenLayers updated their stable version from version 2.7 to version 2.8. I don't know why, but this seems to have broken the Admin OSM implementation, even though the admin implementation still uses version 2.7. See this thread:

http://groups.google.com/group/geodjango/browse_thread/thread/139f0e7013a87c78

The attached patch seems to resolve the issue by using OpenLayers version 2.8 in the admin implementation instead.

Attachments (1)

update_osmadmin_to_OL2.8.diff (577 bytes) - added by yourcelf 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by yourcelf

comment:1 Changed 6 years ago by jbronn

  • milestone set to 1.1
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to fixed
  • Status changed from new to closed

(In r11125) Fixed #11401 -- Update geographic admin to use OpenLayers 2.8 as OpenStreetMap does not support previous versions. Thanks, yourcelf for ticket and patch.

comment:2 Changed 6 years ago by jbronn

(In [11126]) [1.0.X] Fixed #11401 -- Update geographic admin to use OpenLayers 2.8 as OpenStreetMap does not support previous versions. Thanks, yourcelf for ticket and patch.

Backport of 11125 from trunk.

comment:3 Changed 6 years ago by jbronn

In #geodjango, springmeyer identified the root cause: http://trac.openstreetmap.org/changeset/16131.

The OSM JavaScript file that is linked to in the geographic admin was changed to only support OpenLayers 2.8. Glad this was caught before the release.

comment:4 Changed 4 years ago by jacob

  • milestone 1.1 deleted

Milestone 1.1 deleted

Note: See TracTickets for help on using tickets.
Back to Top