Code

Opened 5 years ago

Closed 5 years ago

#11386 closed (duplicate)

manage.py sqlall error msg says it did not find an app when it found it

Reported by: aviahl Owned by: nobody
Component: Core (Management commands) Version: 1.1-beta
Severity: Keywords: sqlall manage.py
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

run $python manage.py sqlall appname
when django FINDS the app but there is an exception in the app's models file, manage.py still says:
"Error: App with label comps_clists_draft could not be found. Are you sure your INSTALLED_APPS setting is correct?"
although it did find the app. maybe that specific exception should give a "apps found, models file has a problem" message

catching this exception occurs at django/db/models/loading.py line 74

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by seveas

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10706

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.