Opened 6 years ago

Closed 6 years ago

#11341 closed (duplicate)

Dot symbols in url in flatpages

Reported by: bugmenot Owned by: nobody
Component: Contrib apps Version: 1.0
Severity: Keywords: flatpages
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi.

Trying to create a page with standard contrib.flatpages module via admin interface. Setting an URL containing a dot in it ( /foo.html ). Expecting to get a page created. But Django doesn't create a page saying "This value must contain only letters, numbers, underscores, dashes or slashes." about URL.
I believe that dot symbol is absolutely OK for URLs.

P.S. And may be it is needed to configure the anti spam software. It thought that the message is spam, but it doesn't contain links at all.

Change History (1)

comment:1 Changed 6 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

#7663 already reported exactly this and has been closed as a dupe of #5192.

The spam checker goes by IP address, I believe (maybe in addition to content). If your ISP's IP range has been associated with spam you won't be able post anonymously (I can't) even the most innocuous content.

Note: See TracTickets for help on using tickets.
Back to Top