Code

Opened 5 years ago

Closed 5 years ago

#11258 closed (duplicate)

Serializers don't stream

Reported by: phaesler Owned by: nobody
Component: Core (Serialization) Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When you pass a stream and an iterator that returns a large number of objects to a serializer (at least JSON and XML), the serializer doesn't start writing to the file until after the iterator has been exhausted (i.e. until all data has been read into memory.) This places an unnecessarily heavy memory overhead on serialising a large data set.

See #5423 for impact on dumpdata.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5423. We don't need a second ticket describing the same problem.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.