#11253 closed (fixed)
TestCase method docs should consistently use TestCase.methodName
Description ¶
Currently we have:
TestCase.assertContains(response, text, count=None, status_code=200) TestCase.assertNotContains(response, text, status_code=200) assertFormError(response, form, field, errors) assertTemplateUsed(response, template_name) assertTemplateNotUsed(response, template_name) assertRedirects(response, expected_url, status_code=302, target_status_code=200)
They're all TestCase
methods so they should all be either with or without the TestCase.
prefix (I say with)
Change History (4)
by , 16 years ago
Attachment: | 11253.diff added |
---|
comment:1 by , 16 years ago
Triage Stage: | Unreviewed → Ready for checkin |
---|
comment:2 by , 16 years ago
Resolution: | → fixed |
---|---|
Status: | new → closed |
comment:3 by , 16 years ago
Note:
See TracTickets
for help on using tickets.
(In [11051]) Fixed #11253 -- Normalized the way the docs refer to TestCase.assert* methods. Thanks to SmileyChris for the report and patch.