Code

Opened 5 years ago

Closed 5 years ago

#11153 closed (duplicate)

django development server needs to trap all exceptions just like mongrel & webbrick does

Reported by: forgacs.attila@… Owned by: nobody
Component: Uncategorized Version: 1.0
Severity: Keywords: test server exception
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If you run "manage.py runserver" there are *some* exceptions
that cause the sandbox server to die. Like SyntaxError, etc...
Developer has to restart test server every time this happens.
Happens a lot ;) OOH, with ruby on rails mongrels and webrick
do not die on any exceptions.
The standard Django Debug exception handler should handle this.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

comment:2 Changed 5 years ago by anonymous

  • milestone 1.1 deleted

comment:3 Changed 5 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9589

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.