Code

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#111 closed defect (duplicate)

Filtering doesn't clean up arguments

Reported by: Manuzhai Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When selecting different filters (DateTimeField-based, in this case), in order:

  • Today: ?datetimeday=20&datetimemonth=7&datetimeyear=2005
  • Then, past 7 days: ?datetimeday=20&datetimegte=2005-07-13&datetimemonth=7&datetimelte=2005-07-20%2023:59:59&datetimeyear=2005

It seems any new arguments should clean up arguments that concern the same field.

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by Manuzhai

Hmm, formatting mangled the URL's..

Today: ?datetime__day=20&datetime__month=7&datetime__year=2005
Then, past 7: ?datetime__day=20&datetime__gte=2005-07-13&datetime__month=7&datetime__lte=2005-07-20%2023:59:59&datetime__year=2005

comment:2 Changed 9 years ago by wilson

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.