Code

Opened 5 years ago

Closed 4 years ago

#11091 closed (invalid)

SSL POST hangs if view function does not use POST object

Reported by: bensmith Owned by: nobody
Component: HTTP handling Version: 1.0
Severity: Keywords: ssl form post
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Here's how to reproduce:

  1. Setup a simple view function.

def myview(request):

return render_to_response('mytemplate.html')

  1. Write a simple form containing one named value that POSTs to the view:

<form method="POST" action="https://www.mysite.com/myview">

<input type="hidden" name="param" value="value"/>
<input type="submit"/>

</form>

  1. Submit the form

The browser will send the POST but no data will be returned. ssl_access.log and ssl_error.log will not have any record of the POST.

You can also do the submit with curl like this:

curl -v -d test=value https://www.mysite.com/myview

curl will just hang after telling you that it's submitted the request.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by SmileyChris

  • Component changed from Template system to HTTP handling
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I'm wondering if this is a Django or a web server problem.

comment:2 Changed 5 years ago by seveas

I don't see that problem using apache 2 with mod_fcgi on rhel4.

comment:3 Changed 4 years ago by russellm

  • Resolution set to invalid
  • Status changed from new to closed

Closing due to a lack of feedback and a counter example saying the problem doesn't exist.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.