Code

Opened 5 years ago

Closed 5 years ago

#11009 closed (duplicate)

Auth PasswordResestTest fails since changeset 10599 - Ticket #8752

Reported by: laureline.guerin@… Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The test class PasswordResetTest was modified in changeset 10599 to init languages in setUp method (Ticket #8752). The parent' setUp is overide, and templates are not found anymore. Tests fail.

ERROR: test_confirm_complete (django.contrib.auth.tests.views.PasswordResetTest)
----------------------------------------------------------------------
Traceback (most recent call last):
...
TemplateDoesNotExist: registration/login.html

Attachments (1)

django_contrib_auth_tests_views.diff (859 bytes) - added by laureline.guerin@… 5 years ago.
patch to fix the bug

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by laureline.guerin@…

patch to fix the bug

comment:1 Changed 5 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from Auth PasswordResestTest fails since sur changeset 10599 - Ticket #8752 to Auth PasswordResestTest fails since changeset 10599 - Ticket #8752
  • Triage Stage changed from Unreviewed to Ready for checkin

comment:2 Changed 5 years ago by SmileyChris

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #10976

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.