Code

Opened 5 years ago

Closed 3 years ago

#10849 closed Uncategorized (duplicate)

management loaddata: bad syntax not reported, results in successful return code

Reported by: pmocek Owned by: nobody
Component: Core (Management commands) Version: 1.0
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When bad syntax is used with the loaddata command of the
auto-generated manage.py, no error is printed at verbosity levels 0
and 1, and manage.py's return code indicates success.

The built-in usage help indicates that the fixture argument is
mandatory:

Usage: manage.py loaddata [options] fixture [fixture ...]

However, when no fixture is specified, the return code from manage.py
indicates success, and an error message is printed only at verbosity
level 2:

$ ./manage.py loaddata ; echo $?
0
$ ./manage.py loaddata --verbosity=1 ; echo $?
0
$ ./manage.py loaddata --verbosity=2 ; echo $?
No fixtures found.
0

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 3 years ago by matiasb

I think this could be closed. It is already fixed (tried 1.2, trunk).

comment:3 Changed 3 years ago by julien

  • Resolution set to duplicate
  • Severity set to Normal
  • Status changed from new to closed
  • Type set to Uncategorized

Dupe of #10200.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.