Code

Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#10770 closed (duplicate)

IntegrityError when creating multiple inline objects with ForeignKey and unique_together

Reported by: rutt Owned by: nobody
Component: contrib.admin Version: 1.1-beta
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Using the models below, enter two Attachment objects with the same slug on the Parent change page, and then save. The result is an IntegrityError where "columns parent_id, slug are not unique". If the two Attachment objects are created and saved individually, the admin shows the expected form error: "Attachment with this Parent and Slug already exists."

Models:

class Parent(models.Model):
    name = models.CharField(max_length=200)
    
class Attachment(models.Model):
    name = models.CharField(max_length=200)
    parent = models.ForeignKey(Parent)
    slug = models.SlugField()
    
    class Meta:
        unique_together = ['parent', 'slug']

Admin:

class ParentAdmin(admin.ModelAdmin):
    inlines = [AttachmentInline]

admin.site.register(Attachment, admin.ModelAdmin)
admin.site.register(Parent, ParentAdmin)

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by rutt

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

See also #10769

comment:2 Changed 5 years ago by mrts

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9493 .

comment:3 Changed 3 years ago by jacob

  • milestone 1.1 deleted

Milestone 1.1 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.