Code

Opened 5 years ago

Closed 5 years ago

#10755 closed (duplicate)

contrib.auth.tests.views.PasswordResetTest fails with custom template

Reported by: Atamert Ölçgen <muhuk@…> Owned by: nobody
Component: Testing framework Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

contrib.auth.tests.views.PasswordResetTest assumes templates are compatible with registration/ templates and installs its own urlconf. My custom registration/ template has a url tag that naturally doesn't exist in django.contrib.auth.urls conf, causing these tests to fail.

ChangePasswordTest OTOH plays nice and installs its own templates. (setUp() & tearDown())

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by arthurk

  • Component changed from Authentication to Testing framework
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 5 years ago by Alex

  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of another ticket that tracks that auth tests fail with custom templates.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.