zero and PositiveIntegerField/PositiveSmallIntegerField
|Reported by:||while0pass||Owned by:||nobody|
|Has patch:||no||Needs documentation:||no|
|Needs tests:||no||Patch needs improvement:||no|
It would be good to state explicitly in documentation that PositiveIntegerField and PositiveSmallIntegerField are integers that are more or equal to zero. The confusion is that zero is not a positive integer. So, it would be good to either extend the relevant documentation subsections with a note on zero, or rename the field subclasses. Unfortunately, "NonNegativeIntegerField" looks rather unwieldy.