Code

Opened 5 years ago

Closed 5 years ago

#10709 closed (duplicate)

Please clarify what objects are accepted by get_object_or_404

Reported by: zgoda Owned by: nobody
Component: Documentation Version: master
Severity: Keywords: shortcuts
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The description for get_object_or_404 does not state what types of objects are allowed to be queried. Some of these types are described later in function interface description, but the description is incomplete (does not specify which manager is used to retireve object).

Attached patch to documentation adds the above specification to function description.

Attachments (1)

getobjector404.call.clarification.diff (714 bytes) - added by zgoda 5 years ago.
extended description of acceptable types

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by zgoda

extended description of acceptable types

comment:1 Changed 5 years ago by SmileyChris

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin

comment:2 Changed 5 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

I'm gonna call this a dupe of [11589], fixed in r11531.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.