Opened 6 years ago

Closed 6 years ago

#10511 closed (duplicate)

get_prep_value isn't called on QuerySet.update()

Reported by: sebastian_noack Owned by: nobody
Component: Database layer (models, ORM) Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I had to note that get_prep_value() isn't called when calling QuerySet's update() method. This is a problem, since for example the DateTimeField calls value_to_db_datetime() which truncated milliseconds when using MySQL. Otherwise you get warning from the database server.

Change History (1)

comment:1 Changed 6 years ago by ikelly

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10411, which is already fixed in svn.

Note: See TracTickets for help on using tickets.
Back to Top