Code

Opened 5 years ago

Closed 5 years ago

#10496 closed (duplicate)

root_path in admin is incorrect when "include(admin.site.urls)" is used

Reported by: powerfox Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When I use include(admin.site.urls) root_path is 'admin/' (it's set in init() of AdminSite). So I get wrong links.
I've noticed it's set only in admin_root (and it will be set to '/admin/' in my case), thus when I use deprecated "r'admin/(.*)', gk_admin_site.root" everything is fine.
Comments in the code say, that root_path and root shouldn't be used, but it's still used in admin templates for links like "Log out", "Change password".

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #10061

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.