Code

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10471 closed (duplicate)

django.contrib.admin fails on big tables with foreign keys in list_display

Reported by: arutdag (a) mail dot ru Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: django.contrib.admin fails on big tables
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

django.contrib.admin fails on big tables with foreign keys in list_display. My database contains up to 90K rows with 3 foreign keys.

Reason is in django.contrib.admin.views.main on line 185. Django tries to make huge query.

        if self.list_select_related:
            qs = qs.select_related()

Django version:
1.1 pre-alpha SVN-9765

Database:
MySQL

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #9954

comment:2 Changed 5 years ago by ramiro

oops, I meant duplicate of #9554, sorry

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.