Code

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#1047 closed defect (duplicate)

bug in decorator_from_middleware function

Reported by: junzhang.jn@… Owned by: jacob
Component: Core (Cache system) Version:
Severity: normal Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

when i use cache_page decorator in Python24, I found

@cache_page( 60 * 15 )
def some_view( request ):
    pass

not equals

def some_view( request ):
    pass
some_view = cache_page( some_view , 60 * 15 )

it equals

def some_view( request ):
    pass
some_view = cache_page(60*15)( some_view )

so i think zhe 'cache.txt' and zhe decorator_from_middleware function should be fixed for this bug.
bug i don't know how to do that.

BTW:the cache system is so cool. :D

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by eugene@…

Duplicate of #1015.

comment:2 Changed 8 years ago by eugene@…

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.